Bug report #907

Crash of QGIS 0.9.1 opening attribut table

Added by Yves Jacolin over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Mandriva Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10966

Description

Description :
edit a layer, copy-paste a feature from a layer to another one.
As the attribute table are different between the two layers, when you save your
modification, a windows alert you that there is a problem with the type of the
fields XXX (which is boolean in my test case, and I try to insert text for example).

With the 0.8.0 release, you could open the attribut table, looked for the '-1' id and
change the incorrect data and save the layer. However, with the 0.9.1 release,
QGIS crash when you try to open the attribut table.

History

#1 Updated by Tim Sutton over 12 years ago

This looks like one for Marcos attention

#2 Updated by Jürgen Fischer over 12 years ago

Is this still the case >=commit:bd9f43f1 (SVN r8212)? Which data providers were you using?

#3 Updated by Yves Jacolin over 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

I used PostGIS DataBase. This bug has been corrected. Thanks :)

#4 Updated by Anonymous about 11 years ago

Milestone Version 0.9.2 deleted

Also available in: Atom PDF