Bug report #9045

Font marker symbol not visible in style manager after restarting QGIS

Added by Richard Hartley about 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17699

Description

This problem occurs when adding a the following font marker symbols to the Style Manager:
  1. Non-standard character from a common font e.g. Character À from the Arial Font (code 0 x 192).
  1. After this has been added and QGIS is restarted the character is replaced by a question mark:
  1. Character from a custom font e.g. After installing the OCHA-Icons-Bounded.ttf font available from (https://docs.google.com/file/d/0B1mi3wqgOCjMQTFmbFpHWERpT28/edit?usp=sharing&pli=1) and adding a Font Marker symbol to the style manager,

  1. the symbol is no longer visible in the Style Manager after restarting QGIS.

This problem does not occur in v1.8.0.

arial-nok.png (22.2 KB) Jürgen Fischer, 2014-02-12 07:48 AM

arial-ok.png (22.3 KB) Jürgen Fischer, 2014-02-12 07:48 AM

ocha-nok.png (22 KB) Jürgen Fischer, 2014-02-12 07:48 AM

ocha-ok.png (23 KB) Jürgen Fischer, 2014-02-12 07:48 AM

OCHA-Icons-Bounded.ttf (72 KB) Jürgen Fischer, 2014-02-12 07:48 AM

Associated revisions

Revision 44885511
Added by Jürgen Fischer almost 6 years ago

styles: explictly save symbol XML in UTF-8 (fixes #9045)

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Target version set to Future Release - High Priority
  • Priority changed from High to Severe/Regression

#2 Updated by Martin Dobias almost 6 years ago

Works for me on linux (either case 1 and 2 work as expected)

#3 Updated by Giovanni Manghi almost 6 years ago

  • Affected QGIS version changed from 2.0.1 to master
  • OS version deleted (Vista)
  • Target version changed from Future Release - High Priority to Version 2.2

Martin Dobias wrote:

Works for me on linux (either case 1 and 2 work as expected)

Hi Martin, it does not happen on Linux but it does on Windows.

#4 Updated by Jürgen Fischer almost 6 years ago

#5 Updated by Jürgen Fischer almost 6 years ago

  • File deleted (QGIS_bug_with_font_marker_symbols.doc)

#6 Updated by Jürgen Fischer almost 6 years ago

  • Assignee set to Jürgen Fischer

#7 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF