Bug report #9014

QGis avoid intersection options is creating sliver polygons

Added by George Rodrigues da Cunha Silva almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Digitising
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17669

Description

Hello everyone,

This is a serious bug and it's causing a lot of trouble for us.

We are using Quantum GIS 2.0 in cartography production, specifically land-use digitizing.

We are using the "avoid intersection" option on Quantum GIS, but in some special weird cases, the tool generates a sliver polygon between two other features that were built using the same process (digitizing with "avoid intersection").

In the attachment there is a shapefile which you can see the error. All features were digitized using "avoid intersection" options. When you run a topology checker validation, it correctly shows an error on a sliver created between two other polygons.

We already investigated the order or digitalization (cw or ccw), but that did not give definitive results. We also tried making sure all polygons the intersection happened to have vertices (to be ignored, for sure) and without vertices.

This is hurting us bad. We have 10 GIS Analysts working full-time with Quantum mapping around 1000km2 and we cannot have topological errors like this. It looks like to me that the problem is with the digitizing tool or some underlying library code, as I've looked up on some other posts.

The links are:

#4880

http://osgeo-org.1560.x6.nabble.com/Polygon-digitalization-td5040680.html

teste_polygon.zip (2.42 KB) George Rodrigues da Cunha Silva, 2013-11-06 06:23 AM


Related issues

Related to QGIS Application - Bug report #8174: Polygons digitized in Postgis layer with "Avoid Intersect... Closed 2013-06-26

History

#1 Updated by George Rodrigues da Cunha Silva almost 6 years ago

Just to let you know,

We tried with "enable topological editing" on and off, as suggested by Marco on #4880. The errors still exist.

#2 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #8174

and I agree that this is a HUGE issue for real life work.

Also available in: Atom PDF