Bug report #9011

PostGis 2.1.0 deprecated signature

Added by Damien Couppé almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:2.0.1 Regression?:No
Operating System:Windows XP Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17666

Description

Hi,

Our dba report us that in the postgres database (9.3) log there are some warning:

2013-10-31 08:35:40.031 CET-base=sigpp-user=**********-host=******(4146)ATTENTION:  ST_Estimated_Extent signature was deprecated in 2.1.0. Please use ST_EstimatedExtent
2013-10-31 08:35:40.132 CET-base=sigpp-user=**********-host=******(4146)ATTENTION:  ST_Force_2d signature was deprecated in 2.1.0. Please use ST_Force2D

We have that since we use Qgis 2.0. With the 1.8 version there was no problem.

Cheers,

Dada2801


Related issues

Duplicated by QGIS Application - Bug report #9075: PostGIS >= 2.1 fill logs with "ST_Estimated_Extent signat... Closed 2013-11-17

Associated revisions

Revision 99cee10c
Added by Jürgen Fischer almost 6 years ago

postgres: use st_estimatedextent with postgis >= 2.1 (fixes #9011)

History

#1 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Closed

#2 Updated by Jürgen Fischer almost 6 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF