Bug report #8941

QGIS crashes on Debian 64bit after upgrading python packages

Added by iTech Dev about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System:Debian 64-bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:17608

Description

QGIS was working fine till today, however after doing packages upgrade in my Debian Jessie 64-bit machine QGIS keeps crashing and does not start with Signal 11 abort message

I did uninstall all plugins but it did not help.

When I start QGIS with --noplugins it starts however whenever I click Python Console it crashes again with same error message.

I managed to compile a list of packages that cause the problem. Attached a screenshot of these packages that once got upgraded QGIS crashes. (After recovering my system, I had to lock their version to not be upgraded)

To re-produce the bug, you can install QGIS on any Debian Jessie or Sid based distribution and upgrade to latest packages (I did try on both Debian Jessie and Sid and the problem exists)

Thanks.

45_PM.png (145 KB) iTech Dev, 2013-10-23 02:49 PM

45_PM.png (160 KB) iTech Dev, 2013-10-23 02:57 PM

qgis_gdb_output.txt Magnifier - Qgis.bin GDB output (9.8 KB) Emmanuel Lesouef, 2013-10-30 02:28 AM


Related issues

Related to QGIS Application - Bug report #8947: QGIS crashes after updates on debian Closed 2013-10-24

History

#1 Updated by iTech Dev about 7 years ago

The second attached image shows the current version of the packages before the upgrade and the new version that causes QGIS to crash on startup.

#2 Updated by Giovanni Manghi about 7 years ago

  • Category deleted (Browser)
  • Priority changed from Severe/Regression to High

#3 Updated by Martin Jung about 7 years ago

Just want to add that QGIS 2.1 (dev.) is working just fine.
Seems like the issue has already been fixed in the development version. Anyway right now the stable sources are useless for Debian Jessie as they always crash.

#4 Updated by Emmanuel Lesouef about 7 years ago

I confirm the bug on Debian Testing amd64.

Please see the output of gdb in the attached file when staring the python console.

#5 Updated by Richard Duivenvoorde about 7 years ago

If I understand correct, the QGIS 2.0/stable packages are build with every QGIS release, so against the Debian's at that time.

If Debian testing/unstable is changing libs/versions, at a certain time the QGIS package will break.

The message from our 'packaging department':
"if you want 'stable QGIS' run QGIS stable on Debian stable"

There are two options to run QGIS on Debian unstable/testing:

1) run 'QGIS-testing' instead of 2.0, see: http://www.qgis.org/en/site/forusers/alldownloads.html#id4

2) compile QGIS 2.0 yourself on jessie (really, it is not so difficult, just follow the steps in the INSTALL: https://github.com/qgis/QGIS/blob/release-2_0/INSTALL#L12)

I actually think that we can close this issue then, because it will be 'fixed' with the next QGIS release

#6 Updated by Martin Jung about 7 years ago

@Richard:

See my comment before. It is not about QGIS testing, but about QGIS stable.
On the official download site sources are provided for QGIS stable ( http://www.qgis.org/en/site/forusers/alldownloads.html#id3 ), which right now do not work!
This one here

Jessie (8.x):

deb     http://qgis.org/debian jessie main
deb-src http://qgis.org/debian jessie main

Of course you could compile QGIS yourself or use the testing version (this is what iam doing right now), but why give users an official source for QGIS 2.0 stable Jessie when it doesn't run?
Ether repack it with the new Jessie libs or remove it from the Homepage and tell users to compile it yourself.

#7 Updated by Jürgen Fischer about 7 years ago

Martin Jung wrote:

It is not about QGIS testing, but about QGIS stable.

AFAIK stable is wheezy and jessie isn't released yet.

#8 Updated by Jürgen Fischer about 7 years ago

Martin Jung wrote:

On the official download site sources are provided for QGIS stable ( http://www.qgis.org/en/site/forusers/alldownloads.html#id3 ), which right now do not work!
This one here

Try 2.0.1-3+jessie1.

#9 Updated by Richard Duivenvoorde about 7 years ago

  • Status changed from Open to Closed

I've updated text in Website, to not use QGIS stable on Jessie/Sid anymore.

http://www.qgis.org/en/site/forusers/alldownloads.html#id3

Closing this issue.

Also available in: Atom PDF