Bug report #8894

xls character encoding not handled correctly

Added by Regis Haubourg about 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17572

Description

Hi,
I have been testing widely xls reading with gdal 1.9 in QGIS.
Where ogrinfo reads data correctly, QGIS can't load the datasource when:

- ressource path has spaces or non ascii characters
OR
- Ressource file name has spaces or non ascii characters
OR
- Ressource Data sheet name has spaces or non ascii characters (1 misnamed sheet is sufficient to break any opening)
OR
- field names has spaces or non ascii characters OR start with a number.

I assume some part of the error are due to QGIS since OGR info works well. If not, please tell, I will close and create a ticket in GDAL tracker.

PS: new GDAL 1.10 xlsx driver only fails with datasheet names.

Cheers

History

#1 Updated by Regis Haubourg over 5 years ago

  • Status changed from Open to Closed

Seems better now.

Also available in: Atom PDF