Bug report #8883

The svg path don't work on datadefined property - SVG file

Added by aperi2007 - about 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17562

Description

Hi,

Using the qgis 2.1 dev (32bit).
And try-ing to use the
data defined properties 32bit to choose the SVG file.
Seem that it capable to see the svg symbol,
only if I use the espression and add the full absolute path to where the svg file is available.

If I choose to describe a relative path it don't work.

It seem ignore
the "svg path" in qgis option.

This is not a good situation because add a dependence in the qgis project .
To the folder of the SVG.
Better solution should be to think to the expression as a relative path from one of the svg-path in the global settings of qgis.

Associated revisions

Revision 55727f75
Added by Radim Blazek almost 7 years ago

Support SVG relative paths in SVG cache to enable relative data defined paths. Fixes #8883

History

#1 Updated by Radim Blazek almost 7 years ago

  • Status changed from Open to Closed

#2 Updated by Radim Blazek almost 7 years ago

In f4a7fcb I also added rendering of missing SVG symbol, currently question mark ('?'), in case an SVG file does not exist.

Also available in: Atom PDF