Bug report #8851

Opening the table of attributes is very slow in QGIS master

Added by Giovanni Manghi about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17533

Description

It is lightning fast in QGIS 2.0.1.

I noticed it when opening a 20k attributes table.

Associated revisions

Revision c0b8e9ab
Added by Matthias Kuhn about 6 years ago

[attrtable] Minimize feature requests on load (Fix #8851)

History

#1 Updated by Matthias Kuhn about 6 years ago

It could be related to debug messages being printed in master (which is probably compiled with CMAKE_BUILD_TYPE=Debug) and not in release (with CMAKE_BUILD_TYPE=Release)

Since 38030fd a higher debug level (4) is used for the heavier debug output. Can you check if this solves the issue?

#2 Updated by Matthias Kuhn about 6 years ago

  • Status changed from Open to Feedback

#3 Updated by Giovanni Manghi about 6 years ago

  • Affected QGIS version changed from 2.0.1 to master
  • Status changed from Feedback to Open

Hi Matthias,

just compiled 2f9eba1, still very slow.

thanks for looking into this!

cheers!

#4 Updated by Matthias Kuhn about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF