Bug report #8834

Style for layer spatialite

Added by iacopo zetti over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17524

Description

When I try to modify the style for a spatialite layer of polygons the map is not correctly shown if I choose Categorize or Graduated Renderer. I see the legend in the legend windows, but the map disappears from the map canvas with Graduated and appears in one single color with Categorize. With the same layer exported as shp everything work perfectly.
I tried with 2 computers, one with ubuntu and one with debian wheezy, same problem. Version 2.1 nightly built.


Related issues

Related to QGIS Application - Bug report #8923: SpatiaLite 4: added attributes disappear Closed 2013-10-21

History

#1 Updated by Josef Källgården over 6 years ago

Confirmed on windows 7.
I also think this should be a blocker since it is a regression from QGIS 2.0.

#2 Updated by Matthias Kuhn over 6 years ago

another candidate for fa90fc9?

Please check if this is solved in the latest nightlies.

#3 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Feedback

#4 Updated by Josef Källgården over 6 years ago

Yes, seems to be fixed now.

#5 Updated by iacopo zetti over 6 years ago

I tested the last nightlies and it's ok.

#6 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Feedback to Closed

Thank you for verifying

Also available in: Atom PDF