Bug report #875

crash when saving to shapefile PostGIS layer with missing geoms

Added by pcavallini - almost 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10934

Description

When saving as shapefile a postgis layer, we get:
/qgis-0.9~svn20071216/src/core/qgsvectorfilewriter.cpp:176: OGRGeometry* QgsVectorFileWriter::createEmptyGeometry(QGis::WKBTYPE): Asserzione @0 && "invalid WKB type"' fallita.
and qgis crashes.
This happens when some record does not have a geometry.

History

#1 Updated by Martin Dobias almost 13 years ago

What is the expected behaviour? Ignore records without geometry?

Martin

#2 Updated by Jürgen Fischer over 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

looks like #957

#3 Updated by Anonymous about 11 years ago

Milestone Version 0.9.2 deleted

Also available in: Atom PDF