Bug report #872

Error in C++ plugin templates files

Added by Fernando Pacheco - almost 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Magnus Homann
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10931

Description

I believe that there is an error in the archives plugin.cpp and plugin.h in the src/plugins/plugin_template directory. That error makes the menu QGis act in odd ways.
The problem is that the source code doesn't use the interface to create the toolbar.

Steps to reproduce the error:
1 - create a plugin in C++ with the python script (plugin_builder.py);
2 - compile the plugin;
3 - load the plugin in QGis;
4 - close QGis;
5 - run QGis -> The application menu acts abnormally.
Thanks. Fernando.

patch.tar.gz (764 Bytes) Fernando Pacheco -, 2007-12-16 05:10 AM

History

#1 Updated by Magnus Homann almost 13 years ago

  • Status changed from Open to In Progress

#2 Updated by Magnus Homann almost 13 years ago

This applies also to eVis, thanks for finding it!
I have submitted ticket to eVis

#3 Updated by Magnus Homann almost 13 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

Fixed in ece9d9b5 (SVN r7797), together with some translation fixes.

#4 Updated by Anonymous about 11 years ago

Milestone Version 0.9.2 deleted

Also available in: Atom PDF