Bug report #8717

GRASS launch error (qgis 32bit standalone installer)

Added by Su Yangtse about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:17435

Description

QGIS windows installer. 2.1.0 & 2.0.1
Grass could launch with "libintl-8.dll" in none English environment.

grass-dufour-error.txt Magnifier - Error messages in terminal. (3.42 KB) Tomas Brunclik, 2013-10-09 06:29 AM

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Target version changed from Future Release - Nice to have to Future Release - High Priority
  • Subject changed from Grass launch error. to GRASS launch error (qgis 32bit standalone installer)

As a probable consequence, there is no GRASS plugin in the qgis 32 bit standalone installer.

#2 Updated by Giovanni Manghi about 6 years ago

  • Category changed from GRASS to Build/Install

#3 Updated by Tomas Brunclik about 6 years ago

I have the same problem on Windows 7 32-bit Czech with today downloaded QGIS-OSGeo4W-2.0.1-2-Setup-x86.exe installer. To add more information, the error message window says (translation from Czech): Entry point of procedure libintl_setlocale in dynamically linked library libintl-8.dll was not found.
The window appears several times during startup by Grass GUI icon and after dismising it the last time, the GRASS terminal, which is open during the startup, closes.
The said library file is present in the Program Files\\QGIS Dufour\\bin directory, it is not missing as it happened in some previous installers (just clarification for those familiar with the other issue).
Running "grass64" from OSGEO shell gives output in the attached text file.

#4 Updated by Giovanni Manghi about 6 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

This issues have been fixed in the osgeo4w installers, Now is needed to wait that new standalone installers to be created from osgeo4w packages.

Also available in: Atom PDF