Bug report #8716

QGIS crash setting out parameter in Processing graphical modeler

Added by Luigi Pirelli almost 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.0.1 Regression?:No
Operating System:Debian wheezy Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17434

Description

QGIS version 2.0.1-Dufour
QGIS code revision d57fe58
code from branch release-2_0

reproducible doing these steps in my debian wheezy (Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux)

1) load a raster
2) open Processing graphical modeler
3) add a restar input
4) add GRASS r.aspect algorithm (without setting output) => add in modeler
5) reopen r.aspect and set output => then crash

qgis compiled Debug mode and valgrind support. Attached logs of the crash

qgis-crash-processing6.txt Magnifier (1.44 MB) Luigi Pirelli, 2013-09-28 09:17 AM

qgis-crash-processing1.txt Magnifier (150 KB) Luigi Pirelli, 2013-09-28 09:17 AM

qgis-crash-processing2.txt Magnifier (258 KB) Luigi Pirelli, 2013-09-28 09:17 AM

qgis-crash-processing3.txt Magnifier (181 KB) Luigi Pirelli, 2013-09-28 09:17 AM

qgis-crash-processing4.txt Magnifier (256 KB) Luigi Pirelli, 2013-09-28 09:17 AM

qgis-crash-processing5.txt Magnifier (269 KB) Luigi Pirelli, 2013-09-28 09:17 AM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback
  • Operating System changed from Debian wheesy to Debian wheezy

Tested on Windows (osgeo4w, qgis 32bit), not confirmed. I will do also on Ubuntu.

#2 Updated by Filipe Dias almost 6 years ago

5) reopen r.aspect and set output => then crash

When you did this, did you double-click on "r.aspect" ou did you press "edit"?

#3 Updated by Luigi Pirelli almost 6 years ago

:)
opening with double-clilk generate crash
opening with edit doesn create crash

why? I can't investigate in this moment

Filipe Dias wrote:

5) reopen r.aspect and set output => then crash

When you did this, did you double-click on "r.aspect" ou did you press "edit"?

#4 Updated by Filipe Dias almost 6 years ago

  • Status changed from Feedback to Closed
  • OS version changed from Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux to Linux
  • Resolution set to duplicate

The problem is the double-click, which causes the crash. I've reported this a while ago but unfortunately it hasn't been fixed.

#6785

#5 Updated by Giovanni Manghi over 4 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF