Bug report #8651

legends are broken in qgis master, print layouts

Added by Giovanni Manghi about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Marco Hugentobler
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17382

Description

subject says it all. They work in qgis 2.0.1

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Subject changed from legenda are broken in qgis master, print layouts to legends are broken in qgis master, print layouts

#2 Updated by Mathieu Pellerin - nIRV about 6 years ago

  • Target version changed from 70 to Future Release - High Priority

Steps to reproduce:
1. Create a new project
2. Add two vector layers (number is irrelevant)
3. Create a new composer window
4. Add a legend element

You'll notice the none of the legend items have symbology attached to the labels.

#3 Updated by Johannes Kroeger about 6 years ago

I meant to file the following but this seems to be the same issue (even though it lacks description...).
Can you try if they appear if you switch to a rule-based style? Then it is the same issue like mine. See below.


I made a vector point layer and added one dot with id 1.
It is shown in the qgis window. The style is single symbol by default.
I create a print composer. I add a legend.
The legend in the composer view just reads "Legend", there is no point shown.
The Legend items list in the menu on the right shows my layer title in column "1" and "hidden" in column "2".

I alttab back to the main qgis window.
I change the style to categorized. I choose the id column and hit classify.
Back in the composer I hit "update all" in the legend items panel.
Nothing changes.

Same if I change the style to graduated.

If I change to a rule-based style however and then "update all" in the legend items panel, I can expand the layer title and there is a colored dot. In the composer view legend the dot also appears.

--

I would expected the legend to always show my point style.

#4 Updated by Giovanni Manghi about 6 years ago

Johannes Kroeger wrote:

I meant to file the following but this seems to be the same issue (even though it lacks description...).
Can you try if they appear if you switch to a rule-based style? Then it is the same issue like mine. See below.

yes is the same issue.

#5 Updated by John Tull about 6 years ago

I found that the symbol will also disappear from a legend if you edit the legend item name for an existing project. Creating a new composer in a new qgis project, all legend items lack symbology.

#6 Updated by Simon Dedman about 6 years ago

This issue raised with pictures here - apologies I didn't check hub first.

#7 Updated by John Tull about 6 years ago

  • Assignee set to Marco Hugentobler

#8 Updated by John Tull about 6 years ago

I ran 'git bisect' and tracked it down to:

0edf0d2764f20d2ca6ab4f6ee86d82e63a7259fc is the first bad commit
commit 0edf0d2764f20d2ca6ab4f6ee86d82e63a7259fc
Author: St├ęphane Brunner <>
Date: Fri Sep 13 19:07:27 2013 +0200

Use scale parameter to display concerned class

:040000 040000 bdb0516117004e608963b624b40724289c997b9f 3f6f39b66eaf6b7d42eba34ffca43ca2c93aca53 M src

https://issues.qgis.org/projects/quantum-gis/repository/revisions/0edf0d2764f20d2ca6ab4f6ee86d82e63a7259fc

#9 Updated by Marco Hugentobler about 6 years ago

  • Status changed from Open to Closed

Fixed in c71d87769e0a1a5f7d66c830b62931edff6a1c70

#10 Updated by John Tull about 6 years ago

Works well in trunk now, thanks!

Marco Hugentobler wrote:

Fixed in c71d87769e0a1a5f7d66c830b62931edff6a1c70

Also available in: Atom PDF