Bug report #8650

QGIS 2.0.1 - python-qgis-common broken with Debian Wheezy sources

Added by Martin Jung almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python plugins
Affected QGIS version:2.0.1 Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:17381

Description

Although not much different from content i just made the switch from the QGIS 1.9 dev. version to the 2.0 stable to have the new nice starting screen ;)
I removed all packages and then added the following sources to my sources.list

deb     http://qgis.org/debian wheezy main
deb-src http://qgis.org/debian wheezy main

(from http://www.qgis.org/en/site/forusers/alldownloads.html#linux). No other sources are activated.
Then i downloaded and installed QGIS 2.0 again.

QGIS 2.0 installs just fine, but the python-qgis and python-qgis-common packages have issues:

> The following packages have unmet dependencies:
> python-qgis : Depends: python-qgis-common (= 2.0.1~wheezy1) but it is not installable
> Depends: sip-api-8.1 but it is not installable
> E: Unable to correct problems, you have held broken packages.

I was able to run everything just fine with the debian-nightly sources beforehand, but now the python-qgis bindings are always broken and point to this virtual package (sip-api-8.1). Python-sip is of course installed.

python-sip version 4.15.1-1

uname -a
Linux rechenknecht 3.10-2-amd64 #1 SMP Debian 3.10.7-1 (2013-08-17) x86_64 GNU/Linux

History

#1 Updated by Guilherme Ferrari almost 6 years ago

Hi. I am facing the same problem with Debian Wheezy i386. Checking the repositories it seems that the following packages are still at 1.8.0-3 (for i386):

python-qgis
libqgis-dev
qgis-mapserver
qgis-sqlanywhere
qgis
qgis-plugin-globe
qgis-plugin-grass
qgis-providers

#2 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Feedback

Guilherme Ferrari wrote:

Hi. I am facing the same problem with Debian Wheezy i386. Checking the repositories it seems that the following packages are still at 1.8.0-3 (for i386):

retry please

#3 Updated by Martin Jung almost 6 years ago

The Debian sources now show qgis 2.0.1-2+wheezy as source at least for me.
However the python-qgis bindings still can not be installed due to a depending sip-api-8.1

#4 Updated by Jürgen Fischer almost 6 years ago

Martin Jung wrote:

The Debian sources now show qgis 2.0.1-2+wheezy as source at least for me.
However the python-qgis bindings still can not be installed due to a depending sip-api-8.1

works fine for me. The dependency sip-api-8.1 is provided by python-sip.

$ dpkg -s python-sip
dpkg -s python-sip
Package: python-sip
Status: install ok installed
Priority: optional
Section: python
Installed-Size: 442
Maintainer: Debian Python Modules Team <[email protected]>
Architecture: amd64
Source: sip4
Version: 4.13.3-2
Provides: python2.6-sip, python2.7-sip, sip-api-8.0, sip-api-8.1
Depends: python2.7 | python2.6, python (>= 2.6.6-7~), python (<< 2.8), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.1.1)
Breaks: python-qscintilla (<< 2.4.3-3~), python-qt4 (<< 4.9~), python-qwt3d-qt4 (<< 0.1.7~cvs20090625-7~), python-qwt5-qt4 (<< 5.2.1~cvs20091107+dfsg-6~)
Description: Python/C++ bindings generator runtime library
 SIP is a tool for generating bindings for C++ classes with some ideas
 borrowed from SWIG, but capable of tighter bindings because of its
 specificity towards C++ and Python.
Homepage: http://www.riverbankcomputing.co.uk/software/sip/

#5 Updated by Martin Jung almost 6 years ago

Strange, maybe because iam using a newer version? I could try to downgrade to your version and see if this helps for now.

dpkg -s python-sip
Package: python-sip
Status: install ok installed
Priority: optional
Section: python
Installed-Size: 288
Maintainer: Debian Python Modules Team <[email protected]>
Architecture: amd64
Source: sip4
Version: 4.14.7-4
Provides: sip-api-10.0
Depends: python (>= 2.7), python (<< 2.8), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.1.1)
Breaks: python-qscintilla (<< 2.7.2), python-qt4 (<< 4.10.2~), python-qwt3d-qt4 (<< 0.1.7~cvs20090625-11+), python-qwt5-qt4 (<< 5.2.1~cvs20091107+dfsg-6+b4)
Description: Python/C++ bindings generator runtime library
 SIP is a tool for generating bindings for C++ classes with some ideas
 borrowed from SWIG, but capable of tighter bindings because of its
 specificity towards C++ and Python.
Homepage: http://www.riverbankcomputing.co.uk/software/sip/

EDIT:
Okay, manually downgrading to 4.13.3-2 at least resolved the sip-api-8.1 error. But now a lot of other dependencies are bugging around. I think it might be because i am using the official Debian testing sources (which were previously known as Wheezy).
Are there any sources for the new debian testing -> jessie ?

#6 Updated by Jürgen Fischer almost 6 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Martin Jung wrote:

Okay, manually downgrading to 4.13.3-2 at least resolved the sip-api-8.1 error. But now a lot of other dependencies are bugging around. I think it might be because i am using the official Debian testing sources (which were previously known as Wheezy).
Are there any sources for the new debian testing -> jessie ?

The packages are meant for wheezy. Try the jessie packages (which are likely to break at some point, when jessie evolves - same for the sid packages).

Also available in: Atom PDF