Bug report #8639

QGIS 2.0.1 windows build - matplotlib requires dateutil

Added by Chris Crook almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:17371

Description

Hi

The standalone windows installer for QGIS includes the python matplotlib module required for (among other things?) the contour plugin, but is missing the dateutil module on which it depends. So currently anything trying to use matplotlib will fail :-(

Could the dateutil module be added to the installer please?

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback

This dependency was ok in qgis 1.8 on Windows?

#2 Updated by Chris Crook almost 6 years ago

Hi Giovanni. I never installed the standalone 1.8, so don't know whether it was required or no. Brief research indicates that there is a change in how matplotlib deals with external dependencies (or ships).

http://stackoverflow.com/questions/18280436/importerror-matplotlib-requires-dateutil

has some comments on this ...

#3 Updated by Jürgen Fischer almost 6 years ago

recheck please

#4 Updated by Chris Crook almost 6 years ago

  • Status changed from Feedback to Closed

Yup .. that's fixed it. Brilliant. Thanks

#5 Updated by Jürgen Fischer almost 6 years ago

  • Resolution set to fixed

Also available in: Atom PDF