Bug report #8601

sip: QgsFieldValidator::fixup has versioned and unversioned overloads

Added by Xavier Fung about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:17343

Description

Compiling trunk with sip 4.15 got this error.

Linking CXX shared library ../output/python/qgis/core.so
[ 90%] Built target python_module_qgis_core
[ 90%] Generating gui/sipguipart0.cpp, gui/sipguipart1.cpp, gui/sipguipart2.cpp, gui/sipguipart3.cpp

sip: QgsFieldValidator::fixup has versioned and unversioned overloads
make[2]: *** [python/gui/sipguipart0.cpp] Error 1
make[1]: *** [python/CMakeFiles/python_module_qgis_gui.dir/all] Error 2
make: *** [all] Error 2

QgsFieldValidator.diff Magnifier (818 Bytes) Dražen Odobašić, 2013-09-13 08:43 AM

History

#1 Updated by Dražen Odobašić about 7 years ago

Hi, I've experienced the same error on ArchLinux... The attached patch should work for the sip 4.15.1, however due to problems with updated pyqt4 packages, I had to build the latest development snapshot of pyqt (http://www.riverbankcomputing.com/software/pyqt/download) to make qgis-master compile

#2 Updated by Jürgen Fischer about 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

applied in 2301c914 and 6f9795b0b

Also available in: Atom PDF