Bug report #8600

QGIS 2.0 not working with NTLM proxy

Added by Jeremy Palmer about 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:Plugin Manager
Affected QGIS version:master Regression?:No
Operating System:windows ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17342

Description

When using the python plugin installer with QGIS 1.8 I could authenticate using our corporate NTLM proxy server by entering the following network proxy details: host, port, username, password and selecting HttpProxy. But now under QGIS this is not possible. I see that the new plugin installer was switched over the using the QgsNetworkAccessManager in this 4ecf3ebd0bae19f97f32bb040c9df95967135ba8

Going back and checking WFS and WMS (which use QgsNetworkAccessManager) with QGIS 1.8 I can't actually get proxy support working. So the problem must be that the QgsNetworkAccessManager is not set-up to authenticate with a NTLM proxy server.

This bug should be treated as critical because it will stop a lot of corporates from using QGIS.


Related issues

Related to QGIS Application - Bug report #5212: Proxy settings ignored for layers Closed 2012-03-20

Associated revisions

Revision 7f9a755f
Added by Jürgen Fischer almost 6 years ago

network manager: support system proxy settings on windows (fixes #8600)

History

#1 Updated by Jeremy Palmer about 6 years ago

Here's another related ticket #5212

#2 Updated by Giovanni Manghi about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority
  • Category set to Plugin Manager

#3 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback

Hi Jeremy,

is this really a regression or it wasn't supported either on older qgis releases?

The blocker tag is reserved for regression, so if it isn't, in order to clean the bug queue for this month of bug fixing prior 2.2, I guess it would be needed to lower the priority.

#4 Updated by Jeremy Palmer almost 6 years ago

Yes before the switch happened in the plugin manager NTLM worked for downloading plugins. Other core web access functionality is status quo however.

Cheers
Jeremy

#5 Updated by Jürgen Fischer almost 6 years ago

  • Assignee set to Jürgen Fischer

#6 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Feedback to Open

#7 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF