Feature request #8595

WMTS connections with authentification fails

Added by Lene Fischer about 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Pull Request or Patch supplied:No Resolution:fixed/implemented
Easy fix?:No Copied to github as #:17337

Description

I’m trying to establish a WMTS connection with authentification having the following url:

http://kortforsyningen.kms.dk/orto_foraar?VERSION=1.0.0&LAYER=orto_foraar&request=GetCapabilities&SERVICE=WMTS&login=qgistest&password=qgistestpw

In the WMS/WMTS dialog I can connect get a tile-set to choose and press add. An errormessage is recorded.

This is a part of the string. It gives no login/password:
http://kortforsyningen.kms.dk/orto_foraar?SERVICE=WMTS&REQUEST=GetTile&VERSION=1.0.0&LAYER=orto_foraar&STYLE=default&FORMAT=image/jpeg&TILEMATRIXSET=View1&TILEMATRIX=L11&TILEROW=1405&TILECOL=2802
When I take this part of the string, add my login and password and test in a browser it works fine.

http://kortforsyningen.kms.dk/orto_foraar?SERVICE=WMTS&REQUEST=GetTile&VERSION=1.0.0&LAYER=orto_foraar&STYLE=default&FORMAT=image/jpeg&TILEMATRIXSET=View1&TILEMATRIX=L11&TILEROW=1404&TILECOL=2802&login=qgistest&password=qgistestpw

The login and password in these examples is working, so the connectionstring should work for testingpurposes.

My conclusion: QGIS can retrieve the parameter with the GetCapability but not get the map from Request=GetTile because it doesn´t add the login/password parameter to the request.

Associated revisions

Revision 8248239a
Added by Jürgen Fischer almost 6 years ago

optionally use base url for WMTS GetTile requests (implements #8595)

History

#1 Updated by Lene Fischer almost 6 years ago

This is a huge problem. While digitizing on a poor internet connection AND using on tablet/android.

I can get Google Tile because it is without username and password - but not our own Tileservice bacause QGIS can´t read Request=GetTile because it doesn´t add the login/password parameter to the request.
Please Help on this Bug.

Kind Regards
Lene Fischer

#2 Updated by Jürgen Fischer almost 6 years ago

  • Tracker changed from Bug report to Feature request

It's not a bug. The GetTile request is formed from the GetTile operation information from GetCapabilities. If the server would echo the credential information in the GetTile URL it announces there, it would work. HTTP authentication would also work.

#3 Updated by Jürgen Fischer almost 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

implemented in 8248239

You still need to use an uppercase REQUEST parameter in the GetCapabilities url.

Also available in: Atom PDF