Bug report #8593

python-qgis removes QGIS

Added by Steven Horner about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:Ubuntu raring Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:17335

Description

When installing python-qgis from the nightly build it removes qgis. Trying to install python support so I can get the Sextante processing working.

I have never managed to get batch mode working in Sextante on wither Windows or Ubuntu and I've tried 4 versions in Ubuntu and 2 in Windows. I live in hope.

History

#1 Updated by Giovanni Manghi about 6 years ago

trust me :) batch processing in sextante (now just "processing") works ok, I use it on both Linux and Windows

#2 Updated by Steven Horner about 6 years ago

Have you ever tried batch processing with r.los, it always crashes for me and which QGIS version are you using?

#3 Updated by Giovanni Manghi about 6 years ago

Steven Horner wrote:

Have you ever tried batch processing with r.los, it always crashes for me and which QGIS version are you using?

just run a r.los analysis in batch mode, using the same input DEM, 3 different viewing positions, distances and heights.

This on qgis master (a code revision a few days aolder then the 2.0 tagging) on Ubuntu precise. I use the nightly build repo, the one that works together with the ubuntugis PPA.

#4 Updated by Steven Horner about 6 years ago

I'm a Ubuntu newbie and using raring but I can't for the life of me get a version where it all works. Not sure how to get an older version than the current from the nightly.

Trying to workout 282 viewsheds using r.los which take about 90 minutes each. This takes ages one at a time.

#5 Updated by Giovanni Manghi about 6 years ago

Steven Horner wrote:

I'm a Ubuntu newbie and using raring but I can't for the life of me get a version where it all works. Not sure how to get an older version than the current from the nightly.

Trying to workout 282 viewsheds using r.los which take about 90 minutes each. This takes ages one at a time.

let's solve the original issue first: how do you install qgis in Ubuntu? do you uses a repository? ubuntugis? nightly builds? both?

#6 Updated by Steven Horner about 6 years ago

Thanks,

I followed the instructions on: [[https://issues.qgis.org/projects/quantum-gis/wiki/Download#26-Ubuntu]]

I have tried the following:
sudo apt-get install python-software-properties
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
sudo apt-get install qgis

Which I think gave me 1.8, this then needs the seperate Sextante plugin but this has the known error:

NameError: global name 'os' is not defined

Which is fixed according to the issues log in versions of QGIS from 1.9 onwards when Sextante was included in QGIS as processing. This is why I am trying to get a newer version.

I have also tried the nightly builds using this

deb http://qgis.org/debian-nightly raring main
deb-src http://qgis.org/debian-nightly raring main

gpg --keyserver keyserver.ubuntu.com --recv 47765B75
gpg --export --armor 47765B75 | sudo apt-key add -

QGIS 2.1.0 master installs but I then try to add Python support to get the processing options by typing the below but it removes QGIS.

sudo apt-get install python-qgis

As you can see I am getting nowhere fast.

#7 Updated by Giovanni Manghi about 6 years ago

Ok, you have mixed up things, a common mistake but nothing serious.

First the Sextante plugin for qgis 1.8 is completely outadated: somewhere along qgis 2.0 development sextante merged with qgis (core) and the old plugin was not updated anymore.

So delete any evidence of this old sextante by deleting the folders

./qgis
and
./config/QuantumGis

Then you have a little confusion with the repositories:

The standard ubuntu repositories have kind of old packages like gdal, so this is why it is handy to use the ubuntugis one, because it has newer version of a lot pf packages.

Then if you want to install qgis master (aka development version), you have to add the nightly build repo, but there are 2 nightly repos, one that use the packages from ubuntugis, and the other that uses the ones from the standard ubuntu repos.

It happens that for your Ubuntu release it seems that there are the qgis master packages only in the nightly repo that doesn't use ubuntugis (the one you already added), so I guess that the confusion arises because you have also the ubuntugis one.

So with the package manager remove any trace of gdal, proj4, qgis, grass et al, then remove/disable the ubuntugis repo, refresh sources and install qgis again.

Steven Horner wrote:

Thanks,

I followed the instructions on: [[https://issues.qgis.org/projects/quantum-gis/wiki/Download#26-Ubuntu]]

I have tried the following:
sudo apt-get install python-software-properties
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
sudo apt-get install qgis

Which I think gave me 1.8, this then needs the seperate Sextante plugin but this has the known error:

NameError: global name 'os' is not defined

Which is fixed according to the issues log in versions of QGIS from 1.9 onwards when Sextante was included in QGIS as processing. This is why I am trying to get a newer version.

I have also tried the nightly builds using this

deb http://qgis.org/debian-nightly raring main
deb-src http://qgis.org/debian-nightly raring main

gpg --keyserver keyserver.ubuntu.com --recv 47765B75
gpg --export --armor 47765B75 | sudo apt-key add -

QGIS 2.1.0 master installs but I then try to add Python support to get the processing options by typing the below but it removes QGIS.

sudo apt-get install python-qgis

As you can see I am getting nowhere fast.

#8 Updated by Steven Horner about 6 years ago

Thank you for the help.

Followed all your instructions but when I launch QGIS I got the following error when the splash screen appeared:

Private qgis.db
[ERROR] Can not make qgis.db private copy

When I say ok to that I then got a Python error which I wont copy but looked like it couldn't write to the folder. So I checked the .qgis2 folder and only root had write permission. Changed this and the error message went and I get the processing menu options.

Although I have the same problem when I choose r.los from processing the screen dims slightly and the loading circle just spins and nothing appears. QGIS has basically frozen.

#9 Updated by Steven Horner about 6 years ago

I have just tested a few more of the tools in the Processing Toolbox.
I can run any QGIS geoalgorithms, Geoserver/PostGis, GDAL, Orfeo, Models etc tools without error or at least get the screens to enter parameters. SAGA tells me I am missing dependency but I don't need SAGA.

So it appears it is on the GRASS commands that are not working in the Processing Toolbox which is actually the only thing I need.

#10 Updated by Steven Horner about 6 years ago

Apologies for all these posts but checking /usr/share/qgis/python/plugins/processing/grass

It looks like files could be missing, there is an nvis.py and this does actually load up from the processing toolbox. There are also two folders "description" and "ext" everything looks correct in "description". In "ext" there are 14 files including init.py like v_report.py and r_info.py but no r_los.py and even the r.info wont load.

I could be on the wrong track.

#11 Updated by Giovanni Manghi about 6 years ago

Steven Horner wrote:

I have just tested a few more of the tools in the Processing Toolbox.
I can run any QGIS geoalgorithms, Geoserver/PostGis, GDAL, Orfeo, Models etc tools without error or at least get the screens to enter parameters. SAGA tells me I am missing dependency but I don't need SAGA.

So it appears it is on the GRASS commands that are not working in the Processing Toolbox which is actually the only thing I need.

this is strange, because once you overcome the above issue then grass should work. So the question is: grass standalone works? the qgis/grass plugins works?

#12 Updated by Giovanni Manghi about 6 years ago

I could be on the wrong track.

it does not seems the issue to me, I use sextante/grass on several qgis master machines - both linux and windows - and never seen this issue.

#13 Updated by Steven Horner about 6 years ago

Grass in QGIS works without any problems. Much faster in Ubuntu compared to Windows version.

Still can't get GRASS tools to work in Sextante though, can I debug somehow?

#14 Updated by Giovanni Manghi about 6 years ago

Steven Horner wrote:

Grass in QGIS works without any problems. Much faster in Ubuntu compared to Windows version.

Still can't get GRASS tools to work in Sextante though, can I debug somehow?

the sextante log says something?

#15 Updated by Giovanni Manghi about 6 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

by the way the original issue was invalid, so I'm closing this. If something is wrong with sextante (but I doubt) another more specific ticket must be filed.

Also available in: Atom PDF