Bug report #8569

Renaming a layer with features count

Added by Rémi Bovard almost 7 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Legend
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17315

Description

When renaming a layer with features count turned on, the number is part of the layer name.

rename.png (5 KB) Rémi Bovard, 2014-03-10 01:24 AM

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Status changed from Open to Feedback
  • Category set to Map Legend

This seems to be the intended behaviour, beside the layer name there is the total number of features, beside the symbology classes there is the number of the feature in each class.

#2 Updated by Rémi Bovard almost 7 years ago

Yes I understand the meaning of the number displayed.

What I was pointing it's that when renaming the layer, this number is considered as part of name (and not a metadata of the layer)

#3 Updated by Rémi Bovard over 6 years ago

One of issue that depends of this is that if you rename a layer with features count on, the number is duplicated because it's considered as part of layer name.

See attached screenshot.

To avoid this behaviour, you need to delete the number when renaming the layer.

#4 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Feedback to Open

+1

Looks like dynamic data gets mixed up with static data. Should not be too hard to fix, but I wonder about Martin's plans concerning the legend refactoring and if it will be easiest to take care of at the same time.

#5 Updated by Rémi Bovard about 6 years ago

  • Status changed from Open to Closed

It's resolved in master.

Also available in: Atom PDF