Bug report #8521

DB Manager is not able to delete raster table

Added by Salvatore Larosa about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17277

Description

When attempts to delete a raster table the following error raises:

function droprastertable(unknown, unknown) does not exist
RIGA 1: SELECT DropRasterTable('test', 'demelevation_r')
               ^
NOTA: No function matches the given name and argument types. You might need to add explicit type casts.

because DropRasterTable function is deprecated.

Associated revisions

Revision 3ac0759b
Added by Salvatore Larosa about 6 years ago

[dbmanager] Replace DropRasterTable func (deprecated) with DROP TABLE: fixes #8521

History

#1 Updated by Salvatore Larosa about 6 years ago

I think here is enough a DROP TABLE schema.tablename.
it also removes the references to raster_columns table.

#2 Updated by Salvatore Larosa about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF