Bug report #8497

python console can't open anymore if special character has been written in previous session

Added by Denis Rouzaud almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:High
Assignee:Salvatore Larosa
Category:PyQGIS Console
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:17260

Description

If you have an accent (é in my case) present in console_history.txt, the console can't be open and an error occurs at
https://github.com/3nids/Quantum-GIS/blob/master/python/console/console_sci.py#L296

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Assignee set to Salvatore Larosa

#2 Updated by Salvatore Larosa almost 7 years ago

Hi Denis,
it looks like you have an old code in your fork, that encoding problem has already been fixed recently

please can you update your fork and try again ?

Thanks!

#3 Updated by Denis Rouzaud almost 7 years ago

  • Status changed from Open to Closed

yes, you're right, everything's ok.!!!
thanks!

Also available in: Atom PDF