Bug report #8490

Index shift in check geometry validity tool

Added by Olivier Monod almost 7 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:17255

Description

Small issue with the "check geometry validity" tool in QGIS in menu "Vector=> Geometry Tools".

The tool identify geometry errors with an index that is shifted (n -1) compared with index appearing in the corresponding attribute table.

index_issue.png (165 KB) Olivier Monod, 2013-08-21 12:54 AM

History

#1 Updated by Olivier Monod almost 7 years ago

The problem was identified using mapinfo file. It doesn't show up with ESRI shapefile.

#2 Updated by Jürgen Fischer about 6 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

The attribute table doesn't show the feature id in the row header - it's just a row number in the table. But the geometry validation shows the feature id. Depending on the data source there might be close similarities if you have all features in the attribute table, but for data sources where the ids are not based on the feature order in the data source, you won't see any at all.

#3 Updated by Jürgen Fischer about 6 years ago

  • Resolution changed from worksforme to invalid

Also available in: Atom PDF