Bug report #848

GRASS vector not refreshed after quiting GRASS Edit

Added by Maciej Sieczka - almost 14 years ago. Updated about 12 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:10907

Description

1. add a GRASS vector layer (eg. 'archsites' from spearfish60)

2. set project's projection to match the added layer (ie. EPSG:26713)

3. Edit Grass Vector Layer, quit GRASS Edit

All ok, the layer is refreshed on the canvas (btw, "Grass" should be "GRASS", everywhere).

4. again, Edit Grass Vector Layer, but now zoom in until about scale 1:317753 is reached, quit GRASS Edit then

The layer is not refreshed this time and will never be from now on (as well as no other GRASS vector) until QGIS is restarted.

History

#1 Updated by Maciej Sieczka - almost 14 years ago

It seems that the problem with canvas not being refresehd after quiting GRASS Edit is related to zooming a lot. Take any GRASS vector, set the project's CS and units to whatever you like, open vector in GRASS Edit, zoom in "a lot", quit GRASS Edit. I can't say if there is a certain "zoom in threshold" to reproduce the problem, but it is reproducible with any dataset as far as I can tell if one just zooms in enough.

#2 Updated by Maciej Sieczka - over 13 years ago

Still present in SVN 8095.

#3 Updated by Tim Sutton about 13 years ago

Hi Maciej

I tried to replicate this in a25211d4 (SVN r8949) without success (using spearfish, archsites on ubuntu heron, i386). Can you confirm it is still an issue?

Thanks

Regards

Tim

#4 Updated by Maciej Sieczka - about 13 years ago

  • Status changed from Open to Closed
  • Resolution set to worksforme

Tim,

Indeed I can't reproduce it anymore, in a7bbe620 (SVN r8952). Closing it. Any idea why the issue is gone?

#5 Updated by Tim Sutton about 13 years ago

Hi

I believe it was probably fixed by Marcos render context commits prior to release of 0.11.0.

Regards

Tim

#6 Updated by Anonymous about 12 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF