Bug report #8472

Scalebar unit selection

Added by Brylie Oxley over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:17240

Description

As a cartographer
I would like to select scale bar units independent of base map units
because I need to provide scale bar(s) representing multiple units (e.g. metric and imperial)

Scenario 1: base map units in degrees converted to kilometers
Given a user has a base map with degrees as units
And the user has added a scale bar in print composer
And the scale bar properties have a unit selection section
When the user selects kilometers as the scale bar units
Then the scale bar will display the kilometer value

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

In QGIS master aka 2.0 is already possible, you can switch the scalebar units between map units, meters and feet.

Also available in: Atom PDF