Bug report #847

delimited text import plugin skips the first input point

Added by Maciej Sieczka - almost 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gavin Macaulay -
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10906

Description

Try the attached text file, using space for delimiter. All 8 points are displayed in the "Example text" box when setting up the import, but only 7 are actually imported - the first one is skipped.

utm.csv Magnifier (232 Bytes) Maciej Sieczka -, 2007-12-03 03:25 AM

History

#1 Updated by Jürgen Fischer almost 13 years ago

The first line is expected to carry column titles not data. I quite sure I saw that documented somewhere, when I worked on the german translation. But I can't seem to find it now. This probably needs to be at a more prominent place.

#2 Updated by Gary Sherman almost 13 years ago

First row must be a header row. This is documented on the user guide.

Since we are in string freeze, no changes will be made to the dialog itself until after the 0.9.1 release.

#3 Updated by Gavin Macaulay - almost 13 years ago

  • Status changed from Open to In Progress

#4 Updated by Gavin Macaulay - almost 13 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

Documentation altered in e22b29c3 (SVN r7794) to make the need for a header row clearer.

#5 Updated by Anonymous about 11 years ago

Milestone Version 0.9.2 deleted

Also available in: Atom PDF