Bug report #8448

Avoid intersection fails with different CRS

Added by Lene Fischer over 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17217

Description

Trying to digitize with two - or more - layers. Snapping and Avoid intersection doesn´t work if there is different CRS.

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Operating System deleted (Windows and MAC)
  • Status changed from Open to Feedback

Hi Lene, I tested on both Windows and Linux and I confirm that avoid intersection does not work of layers have different CRS (and for my surprise it is not a regression since qgis 1.8, I would have said that it was), but snapping works ok.

Can you share a sample project/data?

#2 Updated by Giovanni Manghi over 7 years ago

  • Subject changed from Snapping and avoid intersection fails with different CRS to Avoid intersection fails with different CRS

I have tested also 1.7.4 and 1.7.0 and it worked as already described, so I guess is unlikely a regression. So I'm not even sure if it is a bug, probably this would be better tagged as feature request?

#3 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

seems anyway that in current master it all works as expected.

Also available in: Atom PDF