Feature request #8439

Scipy and QGIS integration failures

Added by Claudios Hakuna over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Python plugins
Pull Request or Patch supplied:No Resolution:invalid
Easy fix?:No Copied to github as #:17208

Description

I installed QGIS 1.8.0 using the stand alone package and i have been having problems installing some plugin. I get this massage "Please install scipy (http://scipy.org/) in your QGIS python path". I have tried Anaconda, Winpython and Python x,y, but they all did not solve my problem.
How am I supposed to deal with such a case.
And where exactly am I supposed to install the scipy packages mentioned above in case my failures were as a result of wrong installation directory.

Thank You

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Dear Claudios,

the bug tracker is suited to report issues, not to make questions. Use the users/developers mailing list or gis.stackexchange.com to ask questions.

About your question:

on platforms like Linux and OsX is easy to install such dependencies, on Windows a little less. Anyway scipy is now a dependency of QGIS 2.0 (due in September) so the issue is solved.

If you want to have a copy of qgis 1.8 with scipy you will have to download it manually (look in the pyhton site) and be sure is a version for python 2.7 (the one used by qgis). Then install it. Later you will have to copy a bunch of files from the library installation folder into the qgis installation folder (can't remember now the details).

#2 Updated by Claudios Hakuna over 7 years ago

THank you very much...

Also available in: Atom PDF