Bug report #8402

Selecting/Activating a layer in the layer list causes canvas to redraw

Added by Donovan Cameron over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:1.8.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:17174

Description

I'm using QGIS 1.8 from the OSGeo4W installer on Windows 7.

Everytime I highlight or select a layer in the layer list, the map canvas redraws.
This isn't a big deal when zoomed in, but if I zoom out - having the map redraw itself with lots of data or labels every time I highlight a layer is introducing delays to my workflows.

The option so far is to disable the rendering by unchecking "Render" near the bottom right of the QGIS user interface and then re-enabling it whenever needed.

QGIS_AutoRedraw_when_HighlightingLayers.mp4 - Screen capture (.mp4) showing QGIS automatically redraw the canvas when layers are highlighted. (3.26 MB) Donovan Cameron, 2013-08-02 09:42 AM

History

#1 Updated by Donovan Cameron over 7 years ago

I've been playing with it more and notice that it doesn't redraw when selecting a point layer.

It only seems to affect layers that contain polygons or lines.

I attached a screen capture to show what it looks like.

#2 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from High to Normal
  • Status changed from Open to Feedback

Cannot confirm on master on both Linux and Windows. Please try qgis master and report back.

#3 Updated by Donovan Cameron over 7 years ago

  • Status changed from Feedback to Closed

Looks like it could of been from a plugin on that Windows PC running QGIS 1.8 because the re-render problem is not present in QGIS master.

If I find which plugin, I'll let the maintainer know =)

#4 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to worksforme

Also available in: Atom PDF