Bug report #8360

odbc import fails if table name contain encodecharacters

Added by Regis Haubourg about 6 years ago. Updated 11 months ago.

Status:Closed
Priority:Low
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17140

Description

Reading MS access datasources via ODBC, table that contain special encoded characters are not imported, and raise a error message "invalid datasource".
When dealing with encoding options, field names and content with encoded characters can be correcly imported. TIt looks like encoding options are not used for table name.

Tested with mdb and accdb databases. ODBC DSN created on windows 7 64 bits, using mdb-accdb odbc drivers 14.00.6015.1000 and mdb 6.01.7601.17632.

see attached small databases for test purposes.

qgistest_access_db_encoded_odbc_tablename.zip (58.8 KB) Regis Haubourg, 2013-07-25 04:43 AM

History

#1 Updated by Regis Haubourg over 5 years ago

  • Target version changed from Future Release - High Priority to Future Release - Nice to have

#2 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Regis Haubourg over 1 year ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to Low
  • Description updated (diff)

#4 Updated by Giovanni Manghi over 1 year ago

Hi Regis, why feedback, it needs to be tested on QGIS 3?

#5 Updated by Regis Haubourg over 1 year ago

exactly!

#6 Updated by Regis Haubourg 11 months ago

  • Status changed from Feedback to Closed

Closing, it's a too old issue.

Also available in: Atom PDF