Bug report #8345

DB Manager prompts to enter password when Postgres database is down

Added by Aren Cambre over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17129

Description

If my Postgres database system is completely down, and I try to connect to it using an existing connection in the DB Manager, I get a dialog titled Enter password that prompts me to enter my password.

If my database is down, no amount of password entering is going to fix this. By prompting me for a password and not telling me what's really going on (the database is not available), DB Manager may cause users to waste time checking for things that won't fix the underlying problem.

This may be related to #8344.


Related issues

Duplicates QGIS Application - Bug report #8344: Enter Credentials dialog pops up when it's pointless Closed 2013-07-22

Associated revisions

Revision aa7c4287
Added by Jürgen Fischer over 6 years ago

QgsCredentials: fix sip bindings
dbmanager: QgsCredentials is in core (fixes #8345)

History

#1 Updated by Jürgen Fischer over 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #8344

#2 Updated by Aren Cambre over 6 years ago

  • Resolution deleted (duplicate)
  • Status changed from Closed to Reopened

The dialog here is different. Unlike #8344, it doesn't indicate that the DB is down and asks for nothing other than a password.

#3 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF