Bug report #8302

missing join for label makes QGIS crash

Added by Denis Rouzaud about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:17097

Description

Make a join on a layer
Use a joined field as a label.
Remove joined layer.
Save - reopen
=> crash

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

#2 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Open to Feedback

Using a simple point shape and a csv file it's not reproducable here.

#3 Updated by Denis Rouzaud about 6 years ago

sorry, correction:

Make a join on a layer
Use a joined field as a label.
Remove the join.
Save - reopen
=> crash

I got this with postgres, I did not test with other sources.

#4 Updated by Jürgen Fischer about 6 years ago

Denis Rouzaud wrote:

I got this with postgres, I did not test with other sources.

um, sorry, still not reproducable.

#5 Updated by Giovanni Manghi about 6 years ago

Jürgen Fischer wrote:

Denis Rouzaud wrote:

I got this with postgres, I did not test with other sources.

um, sorry, still not reproducable.

I'm also not able to replicate, used a postgis layer joined with a csv table.

#6 Updated by Salvatore Larosa about 6 years ago

Giovanni Manghi wrote:

Jürgen Fischer wrote:

Denis Rouzaud wrote:

I got this with postgres, I did not test with other sources.

um, sorry, still not reproducable.

I'm also not able to replicate, used a postgis layer joined with a csv table.

Same here.

#7 Updated by Denis Rouzaud about 6 years ago

Sorry, apparently it is related to a common crash when opening a project while another one is already open.

I made a video demo at first showing the crash: with the written procedure:
http://www.youtube.com/watch?v=O5J_aGYlbyQ

But if I open a blank QGIS, I can open the project without any problem, but if I reopen it again, it crashes.

#8 Updated by Giovanni Manghi about 6 years ago

Denis Rouzaud wrote:

Sorry, apparently it is related to a common crash when opening a project while another one is already open.

I made a video demo at first showing the crash: with the written procedure:
http://www.youtube.com/watch?v=O5J_aGYlbyQ

But if I open a blank QGIS, I can open the project without any problem, but if I reopen it again, it crashes.

I have tested again with the same exact steps as in the video, and no crash again. Maybe it depends on the data, can you share a sample?

#9 Updated by Salvatore Larosa about 6 years ago

Denis Rouzaud wrote:

Sorry, apparently it is related to a common crash when opening a project while another one is already open.

I made a video demo at first showing the crash: with the written procedure:
http://www.youtube.com/watch?v=O5J_aGYlbyQ

But if I open a blank QGIS, I can open the project without any problem, but if I reopen it again, it crashes.

Hi Denis,
I can reproduce it just activating the QuicFinder plugin.

I think this issue is not related to QGIS.

Please could you try by deactivating the QuickFinder plugin ?

#10 Updated by Denis Rouzaud about 6 years ago

  • Status changed from Feedback to Closed

You are right.
Thanks a lot for this, I will try to fix the plugin.

Also available in: Atom PDF