Bug report #8264

error when trying to load a layer that wasn't actually created

Added by Filipe Dias about 7 years ago. Updated about 5 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17068

Description

v.clean works correctly with the attached shp (threshold = 0, snap = 0). The cleaned shapefile is added but an error related to the error layer is shown.

test.zip (4.03 MB) Filipe Dias, 2013-07-11 01:55 AM

History

#1 Updated by Giovanni Manghi about 7 years ago

with threshold = 0 the error layer is (should be) empty, so you get the error if using a different value?

#2 Updated by Filipe Dias about 7 years ago

Yes, you are right. If the threshold is set to >0 (which it should always be) no error occurs.

#3 Updated by Giovanni Manghi almost 7 years ago

  • Subject changed from v.clean doesnt create the error layer to error when trying to load a layer that wasn't actually created
  • Category changed from 59 to 63
  • Priority changed from Normal to Low

The issue is more general, any time a module that is "supposed" to create a layer but is does not, then SEXTANTE throws this error because it can't open it. Examples:

v.clean -> if there are no errors to clean, then GRASS does not create any error layer

r.fillnulls -> if there are no nulls to fill, no output is created

#4 Updated by Filipe Dias almost 7 years ago

  • Priority changed from Low to Normal

Maybe a general message should thrown when this happens, such as "The execution of the algorithm didnt produce any shapefiles".

For v.clean r.fillnulls maybe tool-specific warnings should be added. Unexperienced users may interpret the error/warning message as bugs or that there's something else wrong.

#5 Updated by Filipe Dias almost 7 years ago

  • Priority changed from Normal to Severe/Regression

This is a complex but important issue that should be addressed in the next version. Returning a "could not load layer" error sounds too much like a bug.

IMO,the best way to deal with this is to set a general message saying "This algorithm didn't produce any outputs. Please make sure you chose the right parameters. If you have any questions please refer to GIS Stackexchange"

#6 Updated by Giovanni Manghi about 6 years ago

  • Priority changed from Severe/Regression to High

I'm changing this to non-blocker for different reasons:

a blocker means a regression, this should not be the case, and then processing can be always updated as plugin update, so I don't think that even a huge issue should block a qgis release.

#7 Updated by Giovanni Manghi almost 6 years ago

  • Affected QGIS version set to 2.4.0
  • Project changed from 78 to QGIS Application
  • Category deleted (63)
  • Crashes QGIS or corrupts data set to No

#8 Updated by Giovanni Manghi almost 6 years ago

  • Category set to Processing/Core

#9 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

The error message has been improved recently. Moreover in GRASS 7/v.clean the error layer is always created now (even if empty).

Also available in: Atom PDF