Bug report #8255

in edit mode changing primary key discards geometry modifications

Added by Vincent Mora over 6 years ago. Updated about 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17059

Description

If you modify the geometry of a feature (eg move a point) and then change its primary key (with attribute table), the geometry modifications are lost.

This is especially relevant to split features, where you may need to edit the primary key values in order to make them unique (see #7550).

Associated revisions

Revision 24b6e638
Added by Jürgen Fischer about 4 years ago

vector layer: update geometries first before feature id might change (fixes #8255)

Revision e9d2a0ed
Added by Jürgen Fischer about 4 years ago

vector layer: update geometries first before feature id might change (fixes #8255)

(backported from commit 24b6e63)

History

#1 Updated by Jürgen Fischer over 5 years ago

  • Category set to Vectors
  • Subject changed from in edition mode changing primary key discards geometry modifications to in edit mode changing primary key discards geometry modifications

#2 Updated by Jürgen Fischer over 5 years ago

  • Priority changed from Normal to High

#3 Updated by Giovanni Manghi about 5 years ago

  • Category changed from Vectors to Digitising

(amazingly) I can confirm this issue, and is not a regression but something that affects qgis since long aso... (tested down until 1.7.4)...

#4 Updated by Jürgen Fischer about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF