Bug report #8205

Selected rows in attribute table have wrong/too light background color

Added by Andreas Neumann over 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17021

Description

On QGIS master in Windows I have the issue that the selected rows
(when I select the features in the map) in the table are not salient
enough. They appear with a very similar light gray background as every odd row.
This means I cannot easily distinguish an odd row from a selected row.
See this screenshot here:
http://webgis.uster.ch/temp/selected_rows_picked_from_map.png

This is only an issue with the Windows version, not on Ubuntu/KDE,
where these selected rows appear in light blue.

When one scrolls in the table, the selected rows turn into blue.

Associated revisions

Revision 173e1d72
Added by Matthias Kuhn almost 6 years ago

[attrtable] Force default selection color (regardless of window focus)
Fix #8205

History

#1 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Closed

It seems that the colors change, when the (attribute table) window get or looses focus. It therefore is not a QGIS issue, but rather a windows (or Qt) color-theme issue. Go to e.g. the layer properties => fields and select a row in the table. If you give the focus to another window the selection color will also turn gray.

Definitely not a problem from our kitchen, so I'll close this.

If a workaround for this should be implemented (e.g. override default color palette on windows) this should be reopened as a feature request.

#2 Updated by Andreas Neumann over 6 years ago

This is too bad.

It really is a problem in day to day work. It is the part of the core of the GIS work to have table and map side be side and browse in the map and table and see where things are located and what values they have.

Is there nothing we can do? E.g. set the background style/color even if the window with the table does not have the focus?

#3 Updated by Matthias Kuhn almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority
  • Status changed from Closed to Reopened

Reopened due to demand on mailing list.

#4 Updated by Matthias Kuhn almost 6 years ago

Can a windows user give a try to https://github.com/qgis/QGIS/pull/1069
I was coding it pretty much in the dark

#5 Updated by Andreas Neumann almost 6 years ago

Sorry - I don't have a dev environment on Windows. If you put it into master I could test it with the next nightly tomorrow.

Thanks,
Andreas

#6 Updated by Matthias Kuhn almost 6 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF