Bug report #8186

Fail to make spatial index for shapefile, with Japanese string in the file name

Added by yoichi Kayama about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17004

Description

after load shapefile that filename contain Japanese string, when make spatial index at the property dialog, fail.
In directory name with some Japanese character, but all file name are ascii, make spatial index was success.
Only fail file name with some Japanese character ,to make spatial index.

Here is log messeage

OGR3error 1 Layer ‹Œ’¬‘º not recognised.


Related issues

Related to QGIS Application - Bug report #8197: Fail to install vc++2005 runtime during installation with... Closed 2013-06-28
Related to QGIS Application - Bug report #8187: Fail to install plugins online if Windows' user name is J... Closed 2013-06-28
Duplicates QGIS Application - Bug report #7794: Fail create a spatial index with shape file that contain ... Closed 2013-05-09

History

#1 Updated by yoichi Kayama about 6 years ago

I found this problem in binary from OSGeo4w dev . code revision 0cac8b4

#2 Updated by Jürgen Fischer about 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

#3 Updated by kosuke ASAHI about 6 years ago

  • Status changed from Closed to Reopened

QGIS code version d37e03b from OSGeo4W, we still have same problem.

#4 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Reopened to Closed

kosuke ASAHI wrote:

QGIS code version d37e03b from OSGeo4W, we still have same problem.

but it's still a duplicate of #7794

Also available in: Atom PDF