Bug report #8181

groupLayerRelationship method broken in Python

Added by Bernhard Ströbl about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Python plugins
Affected QGIS version:master Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:17000

Description

QGIS master (28efcda) crashes when using iface.legendInterface().groupLayerRelationship() in a project with at least one vector layer loaded
no matter if issued on the Python console or in a plugin

History

#1 Updated by Salvatore Larosa about 6 years ago

  • Status changed from Open to Closed

Hi, try to update your revision, that should be fixed in 1f10010

I am closing as it is a duplicate of #8061

Please reopen if it doesn't work for you !

#2 Updated by Bernhard Ströbl about 6 years ago

Sorry for the noise, I was under the impression of running current master but instead I was running an older version.
Yes it definitely works now!

Also available in: Atom PDF