Bug report #8167

wrong encoding of vector layer opened from command-line or browser

Added by Minoru Akagi about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16990

Description

This is an issue that Borys let me know. When I open shapefiles from command-line or browser, the encoding is set to the last used encoding. Then, if the ignore option is unchecked, I cannot change it to UTF-8. The same thing happens with KML files. There seems to be no problem with drag & drop.

Associated revisions

Revision a13126cf
Added by Minoru Akagi about 6 years ago

OgrProvider: initial encoding setting check (fix #8167)

Revision 2d6c92b8
Added by Borys Jurgiel about 6 years ago

Merge pull request #678 from minorua/ogr_init_enc_chk

OgrProvider: initial encoding setting check (fix #8167)

History

#1 Updated by Minoru Akagi about 6 years ago

pull request to fix this issue: https://github.com/qgis/Quantum-GIS/pull/678

#2 Updated by Borys Jurgiel about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF