Bug report #8159

QgsNetworkAccessManager's request timeout loop is infinite

Added by Borys Jurgiel over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:High
Assignee:Jürgen Fischer
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16985

Description

Once any request is created, a periodic QTimer is started, aborting it every 20 seconds. It seems in some cases the timer gets a dead loop (without any delay), significantly decreasing the GUI responsivity.

Is the use of cyclical timer intentional, or can we add

timer->setSingleShot( true );

to QgsNetworkAccessManager::createRequest ?

Associated revisions

History

#1 Updated by Borys Jurgiel over 7 years ago

  • Subject changed from QgsNetworkAccessManager timeout loop is infinite to QgsNetworkAccessManager's request timeout loop is infinite

#2 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Open to Closed

#3 Updated by Borys Jurgiel over 7 years ago

JEF, the static QTimer::singleShot seems to delete the timer once is executed. It causes an assertion fail in the slot (you haven't noticed it because of a typo in the slot name). I reverted to the good old timer->start in 6cfe4a5fc

Also available in: Atom PDF