Bug report #8148

add warning when trying add to canvas a view without a primary key

Added by Giovanni Manghi over 6 years ago. Updated about 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16976

Description

When trying to add in the canvas a view without a primary key using DB Manager it will fail "silently"***

A error message is issued in the log, but the user can easily miss it.

When adding such view using the standard "add postgis layer" dialog now QGIS issues a much more clear warning that would be nice to be used also for DB Manager:

Capture.JPG (45.5 KB) Giovanni Manghi, 2013-06-24 07:21 AM

Associated revisions

Revision 0a875d3e
Added by Jürgen Fischer about 5 years ago

db manager: show error message in bar when adding a layer fails (fixes #8148)

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Affected QGIS version set to master
  • Priority changed from Normal to High
  • Tracker changed from Feature request to Bug report
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Future Release - Nice to have to Future Release - High Priority

this is a bug, not a feature request.

I should even be a blocker as in the past it was working as expected (I add that many users are finding this new behavior very confusing, especially because in the past was more straightforward).

add a clear message is the least can be done, allowing add views without pk it would be the right thing to do.

#2 Updated by Jürgen Fischer about 5 years ago

  • Subject changed from DB Manager, add warning when trying add to canvas a view without a primary key to add warning when trying add to canvas a view without a primary key

#3 Updated by Jürgen Fischer about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF