Feature request #8112

GetLegendGraphic URL for each Layer in GetCapa

Added by Marco Lechner about 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Marco Hugentobler
Category:QGIS Server
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Easy fix?:No

Description

Some clients need the GetLegendGraphic URl to be provided as child node of Layers-tag in getCapabilities file. I'm not sure but trying to interpret the specs this seems to be the expected behaviour usidng WMS with GetLegendGraphic and Layers, because of the links from WMS-Standard to SLD-Standard. If it is so this should be a Blocker for 2.0

I tried to prepare a fix, but I'm not sure if this should be implemented in qgswmsserver.cpp or in qgsprojectparser.cpp (QgsProjectParser::layersAndStylesCapabilities)

Any hint?

History

#1 Updated by René-Luc ReLuc about 4 years ago

The element you want in the GetCapabilities is not mandatory.

QGIS-Server already provide the URL for GetLegendGraphic and WMS client can construct the URL based on layer name and style name.

I don't think it's a high priority issue.

#2 Updated by Marco Lechner almost 4 years ago

  • Priority changed from High to Normal

Priority changed to normal, because feature is not mandatory.
Anyway pull request 767 https://github.com/qgis/Quantum-GIS/pull/767 adds the LegendURL node to the style section of each layer in GetCapa.

#3 Updated by Marco Lechner almost 4 years ago

  • Pull Request or Patch supplied changed from No to Yes

#5 Updated by Marco Lechner almost 4 years ago

  • Assignee set to Marco Hugentobler

#6 Updated by Marco Lechner almost 4 years ago

new patch (pull request 775: https://github.com/qgis/Quantum-GIS/pull/775) adds customizable legendUrl to vector and rasterlayers and uses layer-specific legendUrl build from main GetLegend Url as fallback.

#7 Updated by Jürgen Fischer almost 4 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#8 Updated by René-Luc ReLuc over 3 years ago

  • Target version changed from Future Release - High Priority to Future Release - Lower Priority

We are in feature freeze, the pull-request will be merged just after release. I have tested it, and it works fine.

#9 Updated by René-Luc ReLuc about 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

This pull request is in master with the commit d6535a8

Also available in: Atom PDF