Bug report #8106

Ftools - Nearest Neighbour does not work

Added by vinayan Parameswaran over 7 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16941

Description

Traceback (most recent call last):
  File "/home/vinayan/gitQgisBuild/output/python/plugins/fTools/tools/doVisual.py", line 228, in run
    ( lst, cnt ) = self.nearest_neighbour_analysis( self.vlayer )
  File "/home/vinayan/gitQgisBuild/output/python/plugins/fTools/tools/doVisual.py", line 415, in nearest_neighbour_analysis
    vprovider.rewind()
AttributeError: 'QgsVectorDataProvider' object has no attribute 'rewind'

Python version:
2.7.3 (default, Aug  1 2012, 05:25:23) 
[GCC 4.6.3]

QGIS version:
1.9.0-Master Master, da0e4f3

History

#1 Updated by Matthias Kuhn over 7 years ago

  • Status changed from Open to Feedback

This seems to be solved, but I stumbled upon some other problems trying it. Can you please test and update the status accordingly.

#2 Updated by Mathieu Pellerin - nIRV over 7 years ago

  • Status changed from Feedback to Closed

I've just verified it working fine here. Closing, please re-open if issue is others have different observations.

#3 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to fixed

#4 Updated by Giovanni Manghi over 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF