Bug report #8083

segfault on wms getfeatureinfo with format=feature (master 449c2a2)

Added by Richard Duivenvoorde over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:16921

Description

When loading a wms (eg http://geodata.nationaalgeoregister.nl/ahn25m/ows and then select layer 'bladindex'), loading is ok.

Then select the i-tool and click in the map.

First time it shows ok (with Format=Html), Text is also ok, but as soon as you choose format 'feature' qgis crashes.

running at in debug mode:

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff4ad3105 in QList<unsigned char*>::append (this=0x3b1, [email protected]: 0x3fde4f0 "") at /usr/include/qt4/QtCore/qlist.h:509
509        if (d->ref != 1) {

list shows:
(gdb) list
504    }
505    
506    template <typename T>
507    Q_OUTOFLINE_TEMPLATE void QList<T>::append(const T &t)
508    {
509        if (d->ref != 1) {
510            Node *n = detach_helper_grow(INT_MAX, 1);
511            QT_TRY {
512                node_construct(n, t);
513            } QT_CATCH(...) {

Associated revisions

Revision 65b0cd92
Added by Jürgen Fischer over 6 years ago

fix #8083 (MultiSurfaces not supported)

History

#1 Updated by Giovanni Manghi over 6 years ago

is this a regression since 1.8 and/or previous master versions?

#2 Updated by Richard Duivenvoorde over 6 years ago

no, don't think so. Switching between the different output formats was not available in 1.8 yet

#3 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF