Bug report #8023

if using edit widget "value map" then the value in the table of attributes are shown between "()"

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16869

Description

subject says it all,

pick a vector and set the edit widget "value map" for a text column with values in it, this are show between "()".

It seems to be just a visualization issue, as the values are not actually changed. Is still very puzzling for users and also wrong, because if opening the form with the right button ("open form"), the widget will not show the right value.

I may affect other widgets. Tested on master with shapes and postgis.

History

#1 Updated by Jürgen Fischer over 6 years ago

not reproducable here. () means that the value doesn't exist in the map. Maybe you have your map reverse (first column attribute value, second column description to show instead of the value).

#2 Updated by Giovanni Manghi over 6 years ago

Jürgen Fischer wrote:

not reproducable here. () means that the value doesn't exist in the map. Maybe you have your map reverse (first column attribute value, second column description to show instead of the value).

let me check

#3 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

ok. It is anyway a behavior different from 1.8, so I guess we should document it (if not already).

#4 Updated by Jürgen Fischer over 6 years ago

  • Resolution deleted (invalid)

Giovanni Manghi wrote:

ok. It is anyway a behavior different from 1.8, so I guess we should document it (if not already).

It is? That's news to me.

Also available in: Atom PDF