Bug report #8007

sextante modeler doesn't allow for file input in orfeo toolbox algorithms

Added by Mathieu Pellerin - nIRV over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:16857

Description

Sextante modeler doesn't allow for file input to be used with Orfeo Toolbox algorithms, even though the same algorithms allow for file input when used outside of the modeler.

Steps to reproduce:
1. Open a new sextante modeler window
2. Insert a file input, name it 'test_file'
3. Insert a raster layer input, name it 'test_raster_layer'
4. Insert the 'image resampling with a rigid transformation' orfeo toolbox algorithm
5. Open the 'input image' list box in the algorithm setting window, and notice the abscence of the 'test_file' file input

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

I don't confirm, in that tool 'input image' is reserved for a raster input.

If you try other tools, where there are file inputs (like Ortho-rectification "geoid file"), it works here.

#2 Updated by Victor Olaya over 7 years ago

  • Priority changed from High to Normal

I guess that what he means is that, although is a raster input, you should be able to use a file, like in the toolbox

This should be moved to a feature request instead of bug

#3 Updated by Mathieu Pellerin - nIRV over 7 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Alright, the problem was with the user, me, not sextante :)

I was mislead into thinking that a "File" input meant a {vector,raster} file, while "Raster Layer" / "Vector Layer" were inputs for QGIS {vector,raster} layers.

Glad we only had to fix... me. :) That said, I think the "File" label is somewhat misleading and can lead to others being confused too. Maybe it could be re-labelled as "File (non-spatial)"?

Closing this invalid bug.

Also available in: Atom PDF