Bug report #7995

kml / mapinfo's mif broken in latest qgis master

Added by Mathieu Pellerin - nIRV over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Radim Blazek
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:16846

Description

This regressed quite recently. Possibly d4945db8?

QGIS doesn't display features of loaded .kml and .mif files. The user can open the files but the resulting layer has no geometry, as well as style and label options missing.

Steps to reproduce:
1. Load the attached {kirirom_1.kml, TerrorConcession.mif}
2. Notice the missing geometry as well as missing style and label in the layer property window

I'm flagging this as corrupted since projects will be missing geometries when rendering.

kirirom_1.kml (9.84 KB) Mathieu Pellerin - nIRV, 2013-06-03 09:58 PM

TerrorConcession.mif (450 Bytes) Mathieu Pellerin - nIRV, 2013-06-03 09:58 PM

TerrorConcession.mid (2 Bytes) Mathieu Pellerin - nIRV, 2013-06-03 09:58 PM

Associated revisions

Revision 383e7f1d
Added by Radim Blazek over 6 years ago

OGR layers with unknown geometry type containing single geometry type fix, fixes #7995

History

#1 Updated by Mathieu Pellerin - nIRV over 6 years ago

Note: this might actually affect more than the two formats mentioned above, I just didn't have other formats available on this computer.

#3 Updated by Radim Blazek over 6 years ago

  • Status changed from Open to Closed

#4 Updated by Radim Blazek over 6 years ago

I was not able to reproduce it with kml, but hopefully the problem was the same as for mif and it depends on GDAL version if it happens also with kml.

#5 Updated by Mathieu Pellerin - nIRV over 6 years ago

  • % Done changed from 0 to 100

Radim, thanks that was fast. I'll re-open if the kml file is still an issue on the enxt osgeo4w build.

#6 Updated by Mathieu Pellerin - nIRV over 6 years ago

Just confirmed we're back on track; .kml / .mif working perfectly on windows 7 and linux.

Also available in: Atom PDF