Bug report #7922

Editing: feature merging crashes QGIS when selecting a row and take attributes from selected feature

Added by Andreas Neumann over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:16793

Description

Steps to reproduce:

  • Create empty shapefile
  • digitize two adjacent lines that can be merged
  • select the two lines
  • open the "Merge selected features" tool
  • Select one of the two rows
  • Press "Take attributes from selected feature"

--> QGIS crashes

linien.zip (1.42 KB) Andreas Neumann, 2013-06-03 04:40 AM


Related issues

Duplicates QGIS Application - Bug report #7668: Merge feature tools causes Qgis crash Closed 2013-04-22

Associated revisions

Revision e53aa076
Added by Matthias Kuhn over 6 years ago

Merge features: Fix "take attributes from selected feature"
Fix #7668
Fix #7922

History

#1 Updated by Jürgen Fischer over 6 years ago

  • Assignee set to Jürgen Fischer

#2 Updated by Andreas Neumann over 6 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

#3 Updated by Jürgen Fischer over 6 years ago

Anything special about the created shapefile? Not reproducable here.

#4 Updated by Alessandro Ciali over 6 years ago

It seems the same behaviour of #7668

#5 Updated by Andreas Neumann over 6 years ago

no - I just used a new empty line shapefile with one id (type integer) and one attribute ("name" --> type String).

Attached you can see my empty testfile.

#6 Updated by Andreas Neumann over 6 years ago

  • Operating System set to Windows

just - tested on Linux. The problem does not exist on Linux - but it appears on Windows with the nightly from last night.

#7 Updated by Andreas Neumann over 6 years ago

Tested with the latest nightly on Windows (OSGeo4W) and the problem is gone. Yesterday it still crashed.

Strange - did you do anything about this bug?

#8 Updated by Andreas Neumann over 6 years ago

There is still the issue of vanishing attributes --> see #7668 which is sort of a duplicate of this bug.

#9 Updated by Giovanni Manghi over 6 years ago

Andreas Neumann wrote:

There is still the issue of vanishing attributes --> see #7668 which is sort of a duplicate of this bug.

There is also the issue when using the functions min/max/median in a integer/float column, that leads to zeroes after the merge.

#10 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Feedback

Please test if 7d38eac solved this issue.

#11 Updated by Salvatore Larosa over 6 years ago

  • Operating System deleted (Windows)

confirmed on Linux.

backtrace: http://codepad.org/aebehHO2

#12 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF