Bug report #790

Crash while digitizing line

Added by sgillies - almost 13 years ago. Updated almost 13 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10849

Description

QGIS 0.9.0 on Windows 2000.

I attempted to digitize a line from a large TIFF (100MB).

Created a new shapefile and zoomed in. Clicked along the raster merrily with no problems until I approached the edge of the window. Needing to pan while continuing the same line, I naively went to the pan tool in the toolbar and clicked it. Doing so, I lost my digitized line without warning (a bug in itself, I think). Next thing I tried was to select the line editing tool again, and this caused the crash. The problem is reproducible following the steps above. Specifically, the error is:

Unhandled exception in qgis.exe (LIBQGIS_GUI.DLL) 0xC0000005: Access violation

Associated revisions

Revision 5043bf7c
Added by Jürgen Fischer about 10 years ago

fix #790 again

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision da7e57d9
Added by Jürgen Fischer about 10 years ago

fix #790 again

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Gary Sherman almost 13 years ago

As a workaround you can pan while digitizing (or at any other time) by holding down the space bar and moving the mouse.

#2 Updated by Jürgen Fischer almost 13 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 21d8f805 (SVN r7329)

Also available in: Atom PDF