Bug report #7883

Large MSSQL Tables Very Slow To Open

Added by Damien Smith over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/MSSQL
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16757

Description

There is a major delay when adding large, detailed MSSQL maps in QGIS. I have a 500MB+ contour file that loads in less than 1 second in MapServer & MapInfo Pro but QGIS appears to be doing some sort of full scan whenever the table is added via the "Add MSSQL" DB tool or when loading as part of a project.

Once the file is loaded, it renders fine but the delay when opening is a major issue. Loading projects containing lots of regular MSSQL spatial layers is also seems slower than it should be presumably due to the same issue.

I have not yet tested similar files in PostGIS.

Associated revisions

Revision d2831e3f
Added by Nathan Woodrow over 6 years ago

Load extents from geometry_columns. Fix #7883

History

#1 Updated by Anonymous over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF